Back to overview
Downtime

Wayfindit Services Unavailable

Feb 12 at 07:39am PST
Affected services
wayfindit.com
quick.wayfindit.com
review.wayfindit.com
surveyor.wayfindit.com

Resolved
Feb 12 at 07:49am PST

This incident has been resolved.

Updated
Feb 12 at 07:45am PST

We've identified the cause of the issue and are preparing a patch. It should be resolved in 5-10 minutes.

Created
Feb 12 at 07:39am PST

We are investigating reports of service unavailability.